Chat Platform Outage
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 16:11 EDT
Monitoring
We are starting to see recovery of the chat platform and Members are successfully getting help in chat. We are continuing to monitor the situation.
Posted Mar 19, 2024 - 15:42 EDT
Investigating
We are investigating an issue that is affecting our chat platform connecting to Member Support team members. If you need assistance, please reach out to our Support Team via phone at 1-866-679-9129. We apologize for any inconvenience this may cause.
Posted Mar 19, 2024 - 15:27 EDT
This incident affected: Contact (Chat).